Xpedition Enterprise Datasheet Curve Modeler

2023-12-27T23:45:53.000-0500
Analysis and Simulation

Summary


Details

A blue and white logo  Description automatically generated

Abstract:

In this Support Kit, we will show you how to create a model using the Datasheet Curve Modeler. 

We have provided you with a lab guide, sample reference plot image and Designer project.

The lab will guide you through the process of VHDL-AMS model creation by creating a free hand model over a datasheet image using the Datasheet Curve Modeler.

Estimated time to complete: 15 – 30 minutes

Version Information: X-ENTP VX.2.13

Creating a Model Using Datasheet Curve Modeler:
Download Datasheet_Curve_Modeler.zip to your Desktop
  1. Unzip the file to your Desktop
  2. Open ReferencePlot.png found in the Datasheet_Curve_Modeler folder
  3. Type AMS into the Search Bar, open your version of AMS flow (This lab is using Xpedition AMS VX.2.13)
  4. Once open, select File > Open > Project
  5. Navigate to DCM.prj under the Datasheet_Curve_Modeler folder
  6. Simulation > Model and Symbol Wizard
  7. Under the Select Source tab, select Datasheet then click Next
  8. Under the Select/Create Model tab, select Datasheet Curves in the dropdown menu
  9. Click Launch to open the Datasheet Curve Modeler
  10. Start the image capture tool from File > Capture Image
    1. An alternative way is to go to File > Open > Existing Image and navigate to ReferencePlot.png found in the Datasheet_Curve_Modeler folder (image is a .png type)
  11. Click Capture in the Image Capture window
  12. Drag capture tool over open datasheet image
  13. Resize capture tool to enclose image
  14. Click Save As
  15. Enter DCM_res_plot and save to “Desktop\Datasheet_Curve_Modeler” as a jpeg image
  16. Open Data Ranges from Edit > Set Data Range
  17. Enter range and type for x-axis data, in this case x-min = -50 and x-max = 100.
  18. Select Linear for datatype
  19. Enter range and type for y-axis data, in this case y-min = 100 and y-max = 1100
  20. Select Linear for datatype
  21. Confirm form entries
  22. Select Bound Box Mode from Edit > Set Bounding Box
  23. Confirm bounding box instructions
  24. Define graph bounding box
  25. Click on upper-most (xmin, ymax) value
  26. Click on origin (xmin, ymin) value
  27. Click on right-most (xmax, ymin) value
    1. Blue box appears bounding the graph area
  28. Select Add Data Points mode from Edit > Add Data Points
    1. Digitize waveform.
      1. Click left-to-right along waveform to place data points
      2. Data points must be within blue data boundary
      3. Data table is automatically filled-in with data point coordinates
      4. Points must be monotonically increasing along x-axis
    2. Edit data points
      1. Click and drag data points.
      2. Edit values in the data table.
      3. Add data points by right clicking on one datapoint and selecting “Add datapoint” in the menu
NOTE: If you have more than one curve, go to Configure > Number of Curves > Curve Number.  You will go from left to right along the waveform but now there will be multiple datapoints every time you click on the curve. 
NOTE: Restriction of x-axis or y-axis movement of datapoints can be implemented through Configure > Lock Datapoint X or Y Movement
  1. File > Create Model and Save the Data File
  2. Choose model type
    1. For this example, select the resistor as a function of voltage under the Passive tab
  3. Confirm the Save data to file window
    1. Respond to generator prompts
      1. Click OK to open Save As form
      2. Enter text res_vs_volt and save to “Desktop\Designer_Curve_Modler\DMS\hml”
      3. Click Save to save text file and generate model/symbol
      4. Click OK to close model confirmation form
    2. Close the Datasheet Curve
  4. Verify Model Details in the Wizard
    1. VHDL-AMS file name
      1. RES_VS_VOLT.vhd
    2. Model Entity
      1. Defines model parameters and ports, select RES_VS_VOLT
    3. Model Architecture
      1. Describes device behavior, select IDEAL
    4. Click Next
A screenshot of a computer  Description automatically generated
  1. Select/Create Symbol Window
    1. Review model source code
    2. Select the source for symbol graphics
      1. Default: Use the symbol selected in the Datasheet tool
    3. Click Next
A screenshot of a computer  Description automatically generated
  1. Verify Set/Map Parameters Details
    1. Review the parameter table.
      1. If needed, change information in the Value column
      2. Table may be grey if no parameters in the model can be changed
      3. In this example, the table will be blank
    2. Click Finish
  2. Choose Model Library
    1. Select Local Library to save the model into.  Other options include:
      1. Local Project
      2. Default shared library
      3. User defined libraries
    2. Click OK to save the model and close the Model and Symbol Wizard
      1. Model is now available in the Simulation > Search/Place Symbol or DataBook library browsers
  3. A window with the symbol will pop up, this can be closed to return to the schematic.
  4. Delete the placeholder resistor
  5. Open Simulation > Search/Place Symbol
  6. Click the + sign on (Current Project)
  7. Click the + sign on (CREATI~1)
  8. Select and place res_vs_volt
  9. Close Search/Place Symbol
  10. Place res_vs_volt symbol where placeholder resistor used to be
  11. Select Simulation > Simulate
  12. Click on the Multi-Run tab
    1. Select “Sweep Values” under Multi-Run Tab
    2. Check “DC Sweep
    3. Click Parameter Edit
      1. Parameter: Select value seen (should match ID of voltage source)
      2. Sweep Type: Increment
      3. Sweep Start: -50
      4. Sweep Stop: 100
      5. Sweep Increment: 1
      6. Click Ok
image.png
  1. Under the Results tab, select “All Waveforms” in the drop-down menu under DC Waveforms. This will give the waveform for the new resistor that was just placed.
  2. Under the Simulations tab, neither Time-Domain or Frequency Analysis should be enabled
  3. Click Ok
  4. Simulation will perform 151 runs; progress can be seen in the bottom left of the Xpedition tool.
  5. Waveform Analyzer will open once simulation is complete.
  6. Click the + next to y1<yournumber> in the Waveform List
  7. Double click the wave res
  8. The waveform will match the one taken in the Datasheet Curve Modeler
image.png
 

KB Article ID# KB000122505_EN_US

Contents

SummaryDetails

Associated Components

Xpedition AMS